目前新版本的php的安全函数,禁用了 pcnt_ 开头很多函数,然而 workerman 又是借助这些扩展才得以使用。如遇以下问题 ![](https://img.kancloud.cn/d5/39/d5395033d5a8f8031145ff0cc20318ab_865x381.png) ### 解决方法如下 1、确定您 cli 模式的 php的版本,在 shell 中输入 ``` php -v ``` 2、到对应的 php 版本的 php.ini中 将对应的函数删除即可。 >宝塔环境的用户,也可以直接通过对应版本的控制台来操作 ![](https://img.kancloud.cn/0d/d6/0dd651359de9da4dbdd90b017fb8bf8b_1402x1254.png) 点击删除即可